1. Dismiss Notice

Electric problems

Discussion in 'General Tech' started by Cody Wolford, Oct 25, 2015.

  1. Cody Wolford

    Cody Wolford PR Member

    2005 trx 450r- will not start with any oem CDI. And usually everytime I kick/it starts the over heat light will flash and then stop. Well I now no longer have power to the light. Or to rest of quad.
    But when j stuck in an aftermarket CDI it fires right up and no problems I've replaced stator, wire harness, tried a different coil and regulator
    WHAT COULD BE CAUSING IT??!
     
  2. BriarcliffMx

    BriarcliffMx PR Founding Father

    Check all connections, use di-electric grease at every one of them. Check the ground at the frame. If it still only runs on an aftermarket CDI, buy that CDI.
     
  3. Cody Wolford

    Cody Wolford PR Member

    We've done all that ad we can't run the at Cdi because on the top end it has issues. But it works enough for us to be able to start it.
     
  4. GeorgiePorgie

    GeorgiePorgie PR Founding Father

    Location:
    Ohio the 440
    Racing Number:
    740
  5. Meister

    Meister PR Founding Father

    Racing Number:
    649
    More specifically, call Mark Baldwin. He's a genius.
     
  6. BriarcliffMx

    BriarcliffMx PR Founding Father

    Sounds like poor spark.
     
  7. Cody Wolford

    Cody Wolford PR Member

    I called Baldwin and mark wasn't in I'm calling again today. see if it was loss of spark I could understand that. But the over heat light on my bars always flashes when I'm kicking. It flashes with the big gun but doesn't with oem. So to me it's loss of all power
     
  8. BriarcliffMx

    BriarcliffMx PR Founding Father

    He will be back from vacation tomorrow (tuesday).
     
  9. GeorgiePorgie

    GeorgiePorgie PR Founding Father

    Location:
    Ohio the 440
    Racing Number:
    740
    Heck, mark answers the phones most of the time.
     
  10. Cody Wolford

    Cody Wolford PR Member

    Not sure what actually fixed it but I got it running today
    Thanks guys!!!!
     
  11. BriarcliffMx

    BriarcliffMx PR Founding Father

    Unexplained changes are the mark of an electrical issue......killswitch shorting out, bad ground for it?
     
  12. Cody Wolford

    Cody Wolford PR Member

    We checked it but I think it was a combo of the harness and stator.
     

Share This Page