1. Dismiss Notice

led light bar issues

Discussion in 'General Tech' started by BWagner15, Nov 10, 2015.

  1. BWagner15

    BWagner15 PR Member

    I added a 30 in led light bar on the cab protector facing backwards toward the trailer on my semi. Ran negative from light bar to the frame ground stud. Then ran positive wire from hot wire on light bar to factory switch in cab. Light bar turns on and is bright it just makes a high pitch hissing/humming sound. Has anyone ran into this or have a clue what would cause it. Thanks
     
  2. Motodad23

    Motodad23 PR Member

    Racing Number:
    23
    When you say frame ground stud,are you saying light bar frame or truck frame? If its truck frame I would run a shorter ground wire to a bolt you mounted light bar with,you might be picking up something from back feed from another ground wire.idk just my opinion and you know what they say about opinions lol
     
  3. BWagner15

    BWagner15 PR Member

    The frame stud on the frame of the truck, ya I will try that and see if it helps. worth a shot
     
  4. hershey

    hershey PR Elite

    Location:
    Ozone Layer
    Racing Number:
    01
    Im assuming you are using a 12v DC LED connected to 12V DC from the truck? If not and there is an LED driver then I would say the driver is bad.
     
  5. BWagner15

    BWagner15 PR Member

    It is a 30in led off road light bar, I tested the wires at the switch and there was 12.46 vdc to that point. It is hooked up to a factory auxiliary switch in the cab
     
  6. hershey

    hershey PR Elite

    Location:
    Ozone Layer
    Racing Number:
    01
    Use a good meter and check the voltage at the light bar while it is on. If the voltage fluctuates then you have a bad source, if not you have bad LED's
     

Share This Page